Ace engine does not start

Hi, thank you for your awesome Ace forum.

Since last few versions I have trouble running the engine on a Windows 11 Enterprise IoT machine. It runs ok first time after install but stops after I restart the PC and does not work anymore. I tried it on a second PC thinking could be a misconfiguration on mine and got the same result. This second PC never got Acestream installed before.

Here is the log:

2024-07-02 10:54:49,343|MainThread|acestream|init webrtc done 2024-07-02 10:54:49,903|MainThread|acestream|init segmenter done: log_path=C:\Users\JMa\AppData\Roaming\ACEStream\engine\segmenter.log 2024-07-02 10:54:49,903|MainThread|acestream|Start Ace Stream 3.2.7 2024-07-02 10:54:49,903|MainThread|acestream|platform=win32 2024-07-02 10:54:49,903|MainThread|acestream|app=acestream 2024-07-02 10:54:49,903|MainThread|acestream|version=3.2.7 code=3020700 revision=8e2aab9 date=2024-07-01 2024-07-02 10:54:49,903|MainThread|acestream|use_local_db=True 2024-07-02 10:54:49,903|MainThread|acestream|is_gui_mode=1 2024-07-02 10:54:49,903|MainThread|acestream|user_agent=Mozilla/5.0 (Windows NT 6.2) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/60.0.3112.50 Safari/537.36 AceStream/3.2.7 2024-07-02 10:54:49,903|MainThread|acestream|python_version=3.8.5-final-0 2024-07-02 10:54:49,903|MainThread|acestream|enable debug: 0 2024-07-02 10:54:49,903|MainThread|acestream|set debug level: 0 2024-07-02 10:54:49,918|MainThread|acestream.coreapp|pid=7088 2024-07-02 10:54:49,918|MainThread|acestream.coreapp|process monitor initialized 2024-07-02 10:54:49,934|MainThread|acestream|get_default_api_version: 2 2024-07-02 10:54:50,075|MainThread|acestream.coreapp|state_dir='C:\\Users\\JMa\\AppData\\Roaming\\.ACEStream' 2024-07-02 10:54:52,700|MainThread|acestream.coreapp|set_debug_from_ui: level=0 2024-07-02 10:54:52,700|MainThread|acestream.coreapp|set_debug_from_ui: log_file_max_bytes=10485760 2024-07-02 10:54:52,700|MainThread|acestream.coreapp|set_debug_from_ui: log_file_backup_count=1 2024-07-02 10:54:52,700|MainThread|acestream|enable debug: 0 2024-07-02 10:54:52,700|MainThread|acestream|set debug level: 0 2024-07-02 10:54:53,247|MainThread|acestream.SocketHandler.InterruptSocket|bound on 127.0.0.1:64171 2024-07-02 10:54:53,247|MainThread|acestream.SocketHandler.SocketHandler|bind: socket bound: host=0.0.0.0 port=8621 2024-07-02 10:54:53,247|MainThread|acestream.LM|listen on 8621 2024-07-02 10:54:53,325|MainThread|acestream.httpserver|start: addr= port=6878 allow_remote=0 allow_intranet=1 2024-07-02 10:54:53,325|MainThread|acestream.httpserver|start: bound on ('0.0.0.0', 6878) 2024-07-02 10:54:53,403|MainThread|acestream.coreapp|init: open webui page on startup: home 2024-07-02 10:54:53,810|MainThread|acestream|failed to init app: UnboundLocalError("local variable 'url' referenced before assignment") Traceback (most recent call last): File "core.c", line 419, in File "core.c", line 1448, in UnboundLocalError: local variable 'url' referenced before assignment 2024-07-02 10:54:53,825|MainThread|acestream.coreapp|_exit_shutdown: session_port=-1 force=False 2024-07-02 10:54:53,841|MainThread|acestream.coreapp|_exit_shutdown: error Traceback (most recent call last): File "core.c", line 6702, in AttributeError: 'NoneType' object has no attribute 'shutdown'

Thank you so much for your help.

Regards

Hi

I have recently installed Acestream on my laptop and worked great… I add the link to the ace player and loads fine

I subsequently installed it on my PC however whenever I try to stream from teh PC I get a window (above the ace player saying loading) and nothing happens … see screen shot…

[Dropbox]

This did not happen with the laptop…

I tried to reinstalling and used both 3.2.6 and 3.2.61 installers

Im very sorry if the question is very basic… but I dont revcall doing anything different with laptop that wil make it work

ur help would be appreciated

Please, tell us more about your setup - OS version on laptop and PC, is there any special software installed - some third-party AD block/AV/firewall apps, for example?

Did built-in Windows Defender complains for any files during Ace Stream install/start-up or not?

In my case, My OS is Windows 11, my adblock is ¡Navega por la web sin anuncios ni elementos emergentes molestos! on Google Chrome, and thats all. There were not problems at installing Ace Stream with any firewall.
Also, I tried to test with WARP VPN, but the result is also the same.
At close any window, this Ace Stream “We have detected an adblock” window appears later.

Any solution to “local variable ‘url’ referenced before assignment” or ‘NoneType’ object has no attribute ‘shutdown’ errors?

Thanks

Did you always got this error or only when running Ace Stream from desktop shortcut?
Try to run Ace Stream engine from “Start” menu, or if it set to autorun - right click on Ace Stream icon in the system tray and then select “Open Ace Stream”.

Same trouble

1 Like

Hi,

I get the issue all time, even from Start menu. The icon never comes up on system try after launching Ace. What I can tell is the host http://127.0.0.1:6878/ui/home#/ works for a couple of seconds just after launching Ace and then stops. As said, the icon never comes up. What is so striking is it works fine after install until PC gets a reboot and then never works again.

Thanks

I use Default Microsoft Defender, no camplains about Ace Stream files during install/start-up. I even tried disabling it during download and install with same result.

Vladyslav, could you update your log to see if issue relays on the same cause?

Thanks

You can try this:

  • check with Task manager that no any acestream processes is running (if so - stop them with Task manager)
  • delete acesteam.log file in the %appdata%\ACEStream\engine
  • run ace_engine.exe file and check for Ace Stream icon in the systray or for ace_engine.exe process with Task manager.
  • if ace_engine.exe failed to run - copy acesteam.log somewhere and attach as is to the reply on this post.
  • after this step you may try to remove or rename %appdata%\.ACEStream (note dot at start) and run ace_engine.exe again.