How to make Ace Player the default program for video on Windows 10?

In default app settings Ace Player is not listed as one of the options. Right-clicking a file and selecting ‘Always use Ace Player for this type’ doesn’t work.

“Per file” associations should works normally, be sure that any other player do not overwrite them (with active option like “check/set file associations at startup”).

“Ace Player” is based on the outdated version of VLC - it’s not “a Win10 aware”, and don’t support modern codecs (like h265/hevc) or features (such as HDR output). So setting Ace Player as “default player” - is bad idea nowadays, use VLC player instead.

The new VLC is giving me problems with deinterlacing. In VLC 2.0, when you had interlaced file and no deinterlacing, you could just turn on Linear Deinterlacing and it would be fine. Now VLC 3.0 does some automatic deinterlacing and the video is still interlaced with deinterlacing on or off.