No audio from 7.1 track when playing a torrent in Ace Player HD

When playing a torrent in Ace Player HD, there is no sound when selecting 7.1 channel audio track. All other audio tracks (2.0, 5.1) work fine. I usually play remux versions of films (m2ts format).

Google Translate: При воспроизведении поток в Ace игрока HD, нет звука при выборе 7.1-канальный звуковой дорожки. Все другие звуковые дорожки (2.0, 5.1) работает отлично. Я обычно играю ремультиплексирования версии фильмов (формат M2TS).

Please, be more specific:

  • no sound at all (on analog and digital outputs), no 7.1 multichannel sound, but you can play it when downmixing to stereo, player complains about audio codec, etc?
  • can you provide us with sample or link to the file of such kind?

There is no sound at all. The Audio Device options are greyed out. For example, this torrent: (stream/00800.m2ts). There is also no sound in 7.1 track when playing the downloaded file itself.

Wow, “Dolby TrueHD 4614 kbps 7.1 / 48 kHz / 4614 kbps / 24-bit (AC3 Embedded: 5.1-EX / 48 kHz / 640 kbps)” - this is tough one =)

I confirm - no 7.1 sound on this track with Ace Player. Also tried this file on recent versions of VLC player - sound plays with stutter (at least, on my PC). On other hand - MPC-HC with LAV filters plays this file flawlessly.

Bottom line so far: support for such kind of audio is broken even in recent VLC versions. If you prefer to watch video with audio tracks like “Dolby TrueHD 7.1/AC3 EX Embedded”, we recommend to use external player (such as MPC-HC, mentioned above).

Yeah, but if I want to watch it from a torrent file (without having to download the whole file), the only option is Ace Player

Why you think so?
Google Chrome, Ace Stream web extension with Magic Player enabled, and link which you provided earlier:

How do you select which player to use? I don’t see the little arrow and when I click on that icon, Ace Player HD opens.

For Google Chrome (for Mozilla Firefox almost the same):

  1. download and (re)install/(re)enable Ace Stream Web Extension
  2. find it on “Extensions” tab and click “Options” and then “Installed userscripts”. You should see there something like in attached file (“MagicPlayer” with blue circle, which mean that script is ‘Enabled’) - if it so, you’re good.
  3. if not, then you should install this script from and check installation again (2)

Now you can try to open some page with torrent links and see installed script in action.

It turns out I used an old version of Acestream Media. Installed the current one. I can now see the arrow but don’t see MPC-HC in the list, only ‘open in web player’, ‘ace player hd’, ‘windows media player’ and ‘add to playlist’. I have MPC-HC installed

Well, this is weird - are you sure, that you have exactly “MPC-HC” - not something like “MPC-BE” or old “MPC”?
You can try next steps: open MPC-HC, then go to its “Options” and check “File Associations” there - they should be “checked” at least for video content. Or, as last resort - download and install latest version of MPC-HC software.

I had only 64-bit version of MPC-HC. Installed the 32-bit version and now it works! Thank you! The only thing is that it says ‘cannot render file’ when opening not a single remux file, but Blu Ray disc with many files (like in the link for Cloverfield Lane). In Ace Player you can select which file to play from the playlist.