Stream not playing inside the page anymore but on external player


The streams no longer play inside the browser’s web page as usual but on the external player.

How to fix this? I mean to watch them inside the browser again.


We need more info - specify OS and browser name/version, link to site.

Windows 10 on different browsers and two different laptops. I tried Chrome (last update), Opera, Firefox and Edge.

I’ve been using Acestream for months and it was stable and wonderful (50 MB optic fiber in Madrid center), but for some reason it has stopped working well. It stopped being played inside the page and now it either doesn’t work at all (stays black) or opens in external player (which would be OK but I prefer it to be inside the window to cast it to my TV)

Last sunday was the first time I couldn’t watch my Real Madrid game, it didn’t work in any browser or laptop at all, all black.


Oh, and I uninstalled and reinstalled it 3 times. Three! Including windows reboot each time. Your last version.

Behavior like this was observed only on specific site or “everywhere”, including our test page - ?

I only use Acestream to watch the football games from this web site that shows Acestream links for every match (maybe not in all)

I have just tried the test page on Chrome Edge and Opera and it doesnt work. Nothing happens when I click on the buttons below.

  1. Close all browsers and working Ace Stream engine/player. Go to “Control Panel”->“Programs and Features” and uninstall currently installed AceStream software. After removing the software via uninstaller, check if any “AceStream” folders left in %appdata% (see attached image). If they are, remove those folders manually.
  2. Download - and install latest version.
  3. At the installation end agree to “Verify software installation on AceStream web-site”.
    At this stage you can be prompted about extension installation/activation for your web-browser, and shortly after this you should get an AceStream icon in the systray area.
  4. If nothing went wrong and browser not complains about any errors, try to play test videos on the AceStream web site.

Completion of stage 4 is mandatory: if you can’t play a test videos (both live and VOD), then something really wrong - either with your setup or with your network (router/firewall/ISP).

I know. I already did all of that, deleting the folders left in AppData, rebooting, etc. There is a Real Madrid game running right now and all I can see is a black window here.

And - did you check installation on our test site and confirm that everything working properly?
We can’t help you with “third party” sites, but we can try to figure out problem, using a “trusted” site.

  • returning to “opens player instead play in browser” issue - this site has a popup like “Do you want to run AcePlayer or keep watching in browser?”, and offer to save selected option. May be, you misused it?
  • there a bunch of streams offer below video frame - and not all of them working for me.
  • this site really don’t like adblockers - did you have any?

Bottom line: if your setup passed tests on our test page, but fails on certain site - please, blame that site first, not our software.

Thanks a lot for your help.

Actually, problems started when I reinstalled Windows and installed Acestream and got that window asking “Do you want to run AcePlayer or keep watching in browser?”. It doesn’t work ever since, and I don’t remember what I chose, but it stopped running in the window and just not working at all. I am back to the old SopCast, which is much more unstable. I don’t know whatt else to try. I indeed disable adblock too. I’d emphasize that problems started whan I first got that “Do you want to run AcePlayer or keep watching in browser?”

This is still not working in any of my two laptops, even after uninstalling, deleting the remaining folders in my user folder and reinstalling, this is all I get.

Hi. The football league started again and the problem is back.

I can watch it in the AceStream Player but not inside the browser, so I can not send it to the TV by chromecast.

I have uninstalled and deleted the folders in appdata a thousand times and then reinstalled clean. I can see the test video inside the browser in your site perfectly but when it comes to this page it doesn’t work, or better said, it works and then stops working for unkown reason, even when the adblock is disabled.

Please help.


Please, do not ask us for support with problems on “” - ask for support on those site.

Additionally you may try our “P2P search” extension - About | P2P Search | Userscripts | Ace Script Market
It will helps you to search for particular broadcast and play it on any player available (including Chromecast devices).