Support node problem

Hi everyone
I createed my source with VLC http://xxx.xxx.xxx.xxx:8080/race. I have for testing created VM Box and installed ubuntu 18. I tested it with this one and it works fine.

/opt/acestream/acestreamengine --stream-source \
--name "test" \
--title "Test translation" \
--source "http://xx.xx.xx.x:8080/espn" \
--bitrate 300000 \
--publish-dir "/ace/streams" \
--cache-dir "/ace/tmp/streams" \
--skip-internal-tracker \
--tracker "udp://9.rarbg.me:2710/announce" \
--quality HD \
--category sport \
--log-stdout

Now I want to create a private source from my computers VM Box and one or two support nodes from 3thrd party source.

I use this one for my stream source

/opt/acestream/acestreamengine --stream-source \
--name "test" \
--title "Test translation" \
--source "http://xxx.xxx.xxx.xxx:8080/race" \
--bitrate 300000 \
--publish-dir "/ace/streams" \
--cache-dir "/ace/tmp/streams" \
--quality HD \
--category sport \
--log-stdout

It works but when I add support node like --support-node “xx.xxx.xxx.xx:8621” \ I get error
error: argument --support-node-cleanup-interval: invalid int value: ‘http://xx.xx.xx.xx.xx:8621/

and I create support node with this.

/opt/acestream/acestreamengine --stream-support-node \
--url "http://xx.xx.xx.xx/123.acelive" \
--state-dir "/tmp" \
--log-stdout

Support node looks like working with no error but I dont know how to test it.

Your statements do not correspond each other (http://xxx.xxx.xxx.xxx:8080/race vs http://xx.xx.xx.x:8080/espn)

If you can download something from support node - then it works. Refer to readme, examples and scripts at https://github.com/acestream/streaming-utils - they more recent, then examples on wiki.

I think I definitely doing something wrong and now stuck here maybe you know what is causing this error?

root@xxx:~/src/src# python start_streamers.py
Traceback (most recent call last):
  File "start_streamers.py", line 479, in <module>
    main()
  File "start_streamers.py", line 374, in main
    config = Config()
  File "/root/src/src/config.py", line 19, in __init__
    self.config = load_config(curdir, "config.json")
  File "/root/src/src/config.py", line 11, in load_config
    config = json.load(f)
  File "/usr/lib/python2.7/json/__init__.py", line 291, in load
    **kw)
  File "/usr/lib/python2.7/json/__init__.py", line 339, in loads
    return _default_decoder.decode(s)
  File "/usr/lib/python2.7/json/decoder.py", line 364, in decode
    obj, end = self.raw_decode(s, idx=_w(s, 0).end())
  File "/usr/lib/python2.7/json/decoder.py", line 382, in raw_decode
    raise ValueError("No JSON object could be decoded")
ValueError: No JSON object could be decoded

Looks like error in your JSON conf file. Refer https://en.wikipedia.org/wiki/JSON - this file must conform to specific format.

Original config file https://github.com/acestream/streaming-utils/blob/master/config/config-template.json had one too many coma.

But still, I run start_streamers.py get this message but nothing else.

root@xxx:/opt/src/config# python /opt/src/src/start_streamers.py
2019-09-21 12:35:35,259|MainThread|start|0 running instances, loaded 1 streams
2019-09-21 12:35:35,259|MainThread|start|start: engine=stable debug=1 name=Testing port=8640 cache=1073741824

My Configs:

[
    {
        "stream_uid": "Testing",
        "port": 8640,
        "title": "Testing Title",
        "url": "http://xxx.xxx.xxx/master2.m3u8",
        "bitrate": "400000",
        "categories": ["sport"],
        "quality": "HD",
        "type": "hls",
        "upload_to": ["127.0.0.1:8641"],
        "force_monotonic_sequence": 1,
        "extended_logging": 1,
        "engine_version": "stable"
    }
]
{
    "engine_path": {
        "stable": "/opt/acestream-stable/start-engine",
        "beta": "/opt/acestream-beta/start-engine",
        "alpha": "/opt/acestream-alpha/start-engine"
    }
    ,"root": "/opt/app"
    ,"controller": {
        "source_node": "/opt/acestream-stable/config/source_node_config.json",
        "support_node": "http://example.com/support_node/get_config.php",
        "monitor": "http://example.com/monitor/data_receiver.php",
        "metadata_receiver": "http://example.com/source_node/post_data.php"
    }
    ,"dirs": {
        "public": "tmp/public",
        "private": "tmp/private",
        "metadata": "tmp/metadata",
        "log": "tmp/logs",
        "cache": "tmp/cache",
        "pid": "tmp/run",
        "state": "tmp/state"
    }
    ,"trackers": [
        "udp://9.rarbg.me:2710/announce"
    ]
}

Why values for “support_node”, “monitor” and “metadata_receiver” was left intact, as in example (comment out them, if they not needed)? What config you’re trying to run - with one “source node” only or with “source and support” nodes? In second case your config is incomplete - you need config and path to for support node.

At first I want at least to start one stream source. I fixed my config files.

{
    "engine_path": {
        "stable": "/opt/acestream-stable/start-engine"
    }
    ,"root": "/opt/app"
    ,"controller": {
        "source_node": "/opt/acestream-stable/config/source_node_config.json"
    }
    ,"dirs": {
        "public": "tmp/public",
        "private": "tmp/private",
        "metadata": "tmp/metadata",
        "log": "tmp/logs",
        "cache": "tmp/cache",
        "pid": "tmp/run",
        "state": "tmp/state"
    }
    ,"trackers": [
        "udp://9.rarbg.me:2710/announce"
    ]
}
[
    {
        "stream_uid": "2019-09-22_1",
        "port": 8640,
        "title": "2019-09-22_1",
        "url": "http://mysource.fake/master.m3u8",
        "bitrate": "400000",
        "categories": ["sport"],
        "quality": "HD",
        "type": "hls",
        "upload_to": ["127.0.0.1:8641"],
        "force_monotonic_sequence": 1,
        "extended_logging": 1,
        "engine_version": "stable"
    }
]

I was able to start something, but then I try to open .acelive from public folder nothing happens. I disabled the firewall, but when I still try to telnet if 8640 port is lisining I get nothing.

systemd-r 730 systemd-resolve 13u IPv4 14046 0t0 TCP 127.0.0.53:53 (LISTEN)
xinetd 930 root 5u IPv6 15323 0t0 TCP *:23 (LISTEN)
sshd 935 root 3u IPv4 19923 0t0 TCP *:22 (LISTEN)

root@xxx:~# python /opt/src/start_streamers.py
2019-09-22 12:16:06,438|MainThread|start|0 running instances, loaded 1 streams
2019-09-22 12:16:06,441|MainThread|start|start: engine=stable debug=1 name=2019-09-22_1 port=8640 cache=1073741824
2019-09-22 12:16:06,443|MainThread|start|create_transport_files: title=2019-09-22_1 url=http://mysource.fake/master.m3u8 public=/opt/app/tmp/public/2019-09-22_1.acelive private=/opt/app/tmp/private/2019-09-22_1_private.acelive
base_url=http://mysource.fake/master.m3u8 sid=0658d78054251512fd12debd562aa7ffc416aa8f:2019-09-22_1
created: hash=2fe1fe03e7af2b7b7291f3d16c9a4a7412d15cc9
2019-09-22 12:16:06,794|MainThread|start|create_transport_files: retval=0

[details=Spoiler]root@xxx:/opt# tree
.
├── acestream-stable
│ ├── acestream.conf
│ ├── acestreamengine
│ ├── config
│ │ └── source_node_config.json
│ ├── data
│ │ ├── images
│ │ │ ├── acestream16.png
│ │ │ ├── acestream32.png
│ │ │ ├── icon.ico
│ │ │ ├── streamer-16.png
│ │ │ ├── streamer-32.png
│ │ │ └── user_pro.png
│ │ ├── lang
│ │ │ ├── en_EN.lang
│ │ │ └── ru_RU.lang
│ │ ├── plugins
│ │ │ ├── adultswim.py
│ │ │ ├── afreeca.py
│ │ │ ├── afreecatv.py
│ │ │ ├── aftonbladet.py
│ │ │ ├── alieztv.py
│ │ │ ├── antenna.py
│ │ │ ├── ard_live.py
│ │ │ ├── ard_mediathek.py
│ │ │ ├── artetv.py
│ │ │ ├── atresplayer.py
│ │ │ ├── azubutv.py
│ │ │ ├── bambuser.py
│ │ │ ├── beam.py
│ │ │ ├── beattv.py
│ │ │ ├── bigo.py
│ │ │ ├── bilibili.py
│ │ │ ├── bliptv.py
│ │ │ ├── chaturbate.py
│ │ │ ├── cinergroup.py
│ │ │ ├── common_jwplayer.py
│ │ │ ├── common_swf.py
│ │ │ ├── connectcast.py
│ │ │ ├── crunchyroll.py
│ │ │ ├── cybergame.py
│ │ │ ├── dailymotion.py
│ │ │ ├── dingittv.py
│ │ │ ├── disney_de.py
│ │ │ ├── dmcloud_embed.py
│ │ │ ├── dmcloud.py
│ │ │ ├── dogan.py
│ │ │ ├── dogus.py
│ │ │ ├── dommune.py
│ │ │ ├── douyutv.py
│ │ │ ├── dplay.py
│ │ │ ├── drdk.py
│ │ │ ├── euronews.py
│ │ │ ├── expressen.py
│ │ │ ├── filmon.py
│ │ │ ├── filmon_us.py
│ │ │ ├── foxtr.py
│ │ │ ├── furstream.py
│ │ │ ├── gaminglive.py
│ │ │ ├── gomexp.py
│ │ │ ├── goodgame.py
│ │ │ ├── hitbox.py
│ │ │ ├── ine.py
│ │ │ ├── itvplayer.py
│ │ │ ├── kanal7.py
│ │ │ ├── letontv.py
│ │ │ ├── livecodingtv.py
│ │ │ ├── liveme.py
│ │ │ ├── livestation.py
│ │ │ ├── livestream.py
│ │ │ ├── media_ccc_de.py
│ │ │ ├── mediaklikk.py
│ │ │ ├── meerkat.py
│ │ │ ├── mips.py
│ │ │ ├── mlgtv.py
│ │ │ ├── news.py
│ │ │ ├── nhkworld.py
│ │ │ ├── nineanime.py
│ │ │ ├── nos.py
│ │ │ ├── npo.py
│ │ │ ├── nrk.py
│ │ │ ├── oldlivestream.py
│ │ │ ├── openrectv.py
│ │ │ ├── orf_tvthek.py
│ │ │ ├── pandatv.py
│ │ │ ├── periscope.py
│ │ │ ├── picarto.py
│ │ │ ├── piczel.py
│ │ │ ├── powerapp.py
│ │ │ ├── rtlxl.py
│ │ │ ├── rtve.py
│ │ │ ├── ruv.py
│ │ │ ├── sbsdiscovery.py
│ │ │ ├── seemeplay.py
│ │ │ ├── servustv.py
│ │ │ ├── speedrunslive.py
│ │ │ ├── sportschau.py
│ │ │ ├── ssh101.py
│ │ │ ├── streamboat.py
│ │ │ ├── streamingvideoprovider.py
│ │ │ ├── streamlive.py
│ │ │ ├── streamme.py
│ │ │ ├── stream.py
│ │ │ ├── streamupcom.py
│ │ │ ├── svtplay.py
│ │ │ ├── tga.py
│ │ │ ├── tigerdile.py
│ │ │ ├── trt.py
│ │ │ ├── turkuvaz.py
│ │ │ ├── tv360.py
│ │ │ ├── tv3cat.py
│ │ │ ├── tv4play.py
│ │ │ ├── tv8.py
│ │ │ ├── tvcatchup.py
│ │ │ ├── tvplayer.py
│ │ │ ├── twitch.py
│ │ │ ├── ustreamtv.py
│ │ │ ├── vaughnlive.py
│ │ │ ├── veetle.py
│ │ │ ├── vgtv.py
│ │ │ ├── viagame.py
│ │ │ ├── viasat_embed.py
│ │ │ ├── viasat.py
│ │ │ ├── vidio.py
│ │ │ ├── vk.py
│ │ │ ├── wattv.py
│ │ │ ├── webtv.py
│ │ │ ├── weeb.py
│ │ │ ├── younow.py
│ │ │ ├── youtube.py
│ │ │ └── zdf_mediathek.py
│ │ ├── schema_sdb_v6.sql
│ │ └── webui
│ │ ├── cert
│ │ │ └── engine.pem
│ │ ├── css
│ │ │ ├── ace-style.css
│ │ │ ├── bootstrap.css
│ │ │ ├── bootstrap-datetimepicker.min.css
│ │ │ ├── bootstrap-responsive.css
│ │ │ ├── common.css
│ │ │ ├── css.css
│ │ │ ├── font-awesome.min.css
│ │ │ ├── gritter.css
│ │ │ ├── ie.css
│ │ │ ├── jquery.mCustomScrollbar.css
│ │ │ ├── jquery-ui.css
│ │ │ ├── light.css
│ │ │ ├── media.css
│ │ │ ├── popup2.css
│ │ │ ├── popup3.css
│ │ │ ├── popup.css
│ │ │ ├── remote-control.css
│ │ │ ├── scroll.css
│ │ │ ├── seekbar.css
│ │ │ ├── slide-menu.css
│ │ │ ├── style.css
│ │ │ ├── stylesheet.css
│ │ │ ├── ui-menu.css
│ │ │ ├── unicorn.css
│ │ │ └── uniform.css
│ │ ├── fonts
│ │ │ ├── fontawesome-webfont.eot
│ │ │ ├── fontawesome-webfont.svg
│ │ │ ├── fontawesome-webfont.ttf
│ │ │ ├── fontawesome-webfont.woff
│ │ │ └── fontawesome-webfont.woff2
│ │ ├── html
│ │ │ ├── download.html
│ │ │ ├── iframe_playlist_add_item.html
│ │ │ ├── player.html
│ │ │ ├── remote_control.html
│ │ │ ├── server_auth.html
│ │ │ └── server.html
│ │ ├── images
│ │ │ ├── arrows.png
│ │ │ ├── breadcrumb.png
│ │ │ ├── close_36.png
│ │ │ ├── close.png
│ │ │ ├── favicon.ico
│ │ │ ├── glyphicons-halflings.png
│ │ │ ├── glyphicons-halflings-white.png
│ │ │ ├── headBG.png
│ │ │ ├── icon-broadcast.png
│ │ │ ├── icon-copy.png
│ │ │ ├── icon-premium.png
│ │ │ ├── icon-proxy.png
│ │ │ ├── icon-update.png
│ │ │ ├── icon-view.png
│ │ │ ├── loader.gif
│ │ │ ├── logo2.png
│ │ │ ├── logo.png
│ │ │ ├── logo-small.png
│ │ │ └── remote-control
│ │ │ ├── background.png
│ │ │ ├── rc_image_audio.png
│ │ │ ├── rc_image_live.png
│ │ │ ├── rc_image_video.png
│ │ │ ├── rc_next_disabled.png
│ │ │ ├── rc_next_normal.png
│ │ │ ├── rc_next_pressed.png
│ │ │ ├── rc_pause_100.png
│ │ │ ├── rc_pause_25.png
│ │ │ ├── rc_pause_75.png
│ │ │ ├── rc_play_100.png
│ │ │ ├── rc_play_25.png
│ │ │ ├── rc_play_75.png
│ │ │ ├── rc_prev_disabled.png
│ │ │ ├── rc_prev_normal.png
│ │ │ ├── rc_prev_pressed.png
│ │ │ ├── rc_restart_disabled.png
│ │ │ ├── rc_restart_normal.png
│ │ │ ├── rc_restart_pressed.png
│ │ │ ├── rc_select_device_disabled.png
│ │ │ ├── rc_select_device_normal.png
│ │ │ ├── rc_select_device_pressed.png
│ │ │ ├── rc_stop_disabled.png
│ │ │ ├── rc_stop_normal.png
│ │ │ ├── rc_stop_pressed.png
│ │ │ ├── rc_volume_max.png
│ │ │ ├── rc_volume_min.png
│ │ │ └── ring-92.gif
│ │ └── javascript
│ │ ├── bootstrap-datetimepicker.min.js
│ │ ├── bootstrap.js
│ │ ├── broadcasting.js
│ │ ├── clipboard.min.js
│ │ ├── init.js
│ │ ├── jquery-1.10.2.min.js
│ │ ├── jquery.mCustomScrollbar.concat.min.js
│ │ ├── jquery.sticky.js
│ │ ├── jquery-ui.min.js
│ │ ├── lang.en_EN.js
│ │ ├── lang.js
│ │ ├── lang.ru_RU.js
│ │ ├── languages.json
│ │ ├── moment.min.js
│ │ ├── proxy_server.js
│ │ ├── remote-control.js
│ │ ├── seekbar.js
│ │ ├── server.js
│ │ ├── strftime.min.js
│ │ └── uniform.js
│ ├── lib
│ │ ├── acestreamengine
│ │ │ ├── CoreApp.so
│ │ │ ├── Core.so
│ │ │ ├── init.py
│ │ │ ├── init.pyc
│ │ │ ├── live.so
│ │ │ ├── node.so
│ │ │ ├── pycompat.so
│ │ │ ├── pysegmenter.so
│ │ │ ├── streamer.so
│ │ │ └── Transport.so
│ │ ├── beautifulsoup4-4.5.3-py2.7.egg
│ │ ├── bitarray-0.8.1-py2.7-linux-x86_64.egg
│ │ ├── blist-1.3.4-py2.7-linux-x86_64.egg
│ │ ├── enum34-1.1.6-py2.7.egg
│ │ ├── futures-3.0.5-py2.7.egg
│ │ ├── GeoIP-1.3.2-py2.7-linux-x86_64.egg
│ │ ├── html5lib-0.999999999-py2.7.egg
│ │ ├── iso8601-0.1.10-py2.7.egg
│ │ ├── libavcodec.so
│ │ ├── libavcodec.so.56
│ │ ├── libavcodec.so.56.1.100
│ │ ├── libavformat.so
│ │ ├── libavformat.so.56
│ │ ├── libavformat.so.56.4.101
│ │ ├── libavutil.so
│ │ ├── libavutil.so.54
│ │ ├── libavutil.so.54.7.100
│ │ ├── libfdk-aac.so
│ │ ├── libfdk-aac.so.1
│ │ ├── libfdk-aac.so.1.0.0
│ │ ├── libmp3lame.so
│ │ ├── libmp3lame.so.0
│ │ ├── libmp3lame.so.0.0.0
│ │ ├── libswresample.so
│ │ ├── libswresample.so.1
│ │ ├── libswresample.so.1.1.100
│ │ ├── libx264.so
│ │ ├── libx264.so.148
│ │ ├── lxml-3.7.2-py2.7-linux-x86_64.egg
│ │ ├── M2Crypto
│ │ │ ├── ASN1.py
│ │ │ ├── ASN1.pyc
│ │ │ ├── ASN1.pyo
│ │ │ ├── AuthCookie.py
│ │ │ ├── AuthCookie.pyc
│ │ │ ├── AuthCookie.pyo
│ │ │ ├── BIO.py
│ │ │ ├── BIO.pyc
│ │ │ ├── BIO.pyo
│ │ │ ├── BN.py
│ │ │ ├── BN.pyc
│ │ │ ├── BN.pyo
│ │ │ ├── callback.py
│ │ │ ├── callback.pyc
│ │ │ ├── callback.pyo
│ │ │ ├── DH.py
│ │ │ ├── DH.pyc
│ │ │ ├── DH.pyo
│ │ │ ├── DSA.py
│ │ │ ├── DSA.pyc
│ │ │ ├── DSA.pyo
│ │ │ ├── EC.py
│ │ │ ├── EC.pyc
│ │ │ ├── EC.pyo
│ │ │ ├── Engine.py
│ │ │ ├── Engine.pyc
│ │ │ ├── Engine.pyo
│ │ │ ├── Err.py
│ │ │ ├── Err.pyc
│ │ │ ├── Err.pyo
│ │ │ ├── EVP.py
│ │ │ ├── EVP.pyc
│ │ │ ├── EVP.pyo
│ │ │ ├── ftpslib.py
│ │ │ ├── ftpslib.pyc
│ │ │ ├── ftpslib.pyo
│ │ │ ├── httpslib.py
│ │ │ ├── httpslib.pyc
│ │ │ ├── httpslib.pyo
│ │ │ ├── init.py
│ │ │ ├── init.pyc
│ │ │ ├── init.pyo
│ │ │ ├── _m2crypto.py
│ │ │ ├── _m2crypto.pyc
│ │ │ ├── _m2crypto.pyo
│ │ │ ├── __m2crypto.so
│ │ │ ├── m2.py
│ │ │ ├── m2.pyc
│ │ │ ├── m2.pyo
│ │ │ ├── m2urllib2.py
│ │ │ ├── m2urllib2.pyc
│ │ │ ├── m2urllib2.pyo
│ │ │ ├── m2urllib.py
│ │ │ ├── m2urllib.pyc
│ │ │ ├── m2urllib.pyo
│ │ │ ├── m2xmlrpclib.py
│ │ │ ├── m2xmlrpclib.pyc
│ │ │ ├── m2xmlrpclib.pyo
│ │ │ ├── PGP
│ │ │ │ ├── constants.py
│ │ │ │ ├── constants.pyc
│ │ │ │ ├── constants.pyo
│ │ │ │ ├── init.py
│ │ │ │ ├── init.pyc
│ │ │ │ ├── init.pyo
│ │ │ │ ├── packet.py
│ │ │ │ ├── packet.pyc
│ │ │ │ ├── packet.pyo
│ │ │ │ ├── PublicKey.py
│ │ │ │ ├── PublicKey.pyc
│ │ │ │ ├── PublicKey.pyo
│ │ │ │ ├── PublicKeyRing.py
│ │ │ │ ├── PublicKeyRing.pyc
│ │ │ │ ├── PublicKeyRing.pyo
│ │ │ │ ├── RSA.py
│ │ │ │ ├── RSA.pyc
│ │ │ │ └── RSA.pyo
│ │ │ ├── Rand.py
│ │ │ ├── Rand.pyc
│ │ │ ├── Rand.pyo
│ │ │ ├── RC4.py
│ │ │ ├── RC4.pyc
│ │ │ ├── RC4.pyo
│ │ │ ├── RSA.py
│ │ │ ├── RSA.pyc
│ │ │ ├── RSA.pyo
│ │ │ ├── SMIME.py
│ │ │ ├── SMIME.pyc
│ │ │ ├── SMIME.pyo
│ │ │ ├── SSL
│ │ │ │ ├── cb.py
│ │ │ │ ├── cb.pyc
│ │ │ │ ├── cb.pyo
│ │ │ │ ├── Checker.py
│ │ │ │ ├── Checker.pyc
│ │ │ │ ├── Checker.pyo
│ │ │ │ ├── Cipher.py
│ │ │ │ ├── Cipher.pyc
│ │ │ │ ├── Cipher.pyo
│ │ │ │ ├── Connection.py
│ │ │ │ ├── Connection.pyc
│ │ │ │ ├── Connection.pyo
│ │ │ │ ├── Context.py
│ │ │ │ ├── Context.pyc
│ │ │ │ ├── Context.pyo
│ │ │ │ ├── init.py
│ │ │ │ ├── init.pyc
│ │ │ │ ├── init.pyo
│ │ │ │ ├── Session.py
│ │ │ │ ├── Session.pyc
│ │ │ │ ├── Session.pyo
│ │ │ │ ├── ssl_dispatcher.py
│ │ │ │ ├── ssl_dispatcher.pyc
│ │ │ │ ├── ssl_dispatcher.pyo
│ │ │ │ ├── SSLServer.py
│ │ │ │ ├── SSLServer.pyc
│ │ │ │ ├── SSLServer.pyo
│ │ │ │ ├── timeout.py
│ │ │ │ ├── timeout.pyc
│ │ │ │ ├── timeout.pyo
│ │ │ │ ├── TwistedProtocolWrapper.py
│ │ │ │ ├── TwistedProtocolWrapper.pyc
│ │ │ │ └── TwistedProtocolWrapper.pyo
│ │ │ ├── threading.py
│ │ │ ├── threading.pyc
│ │ │ ├── threading.pyo
│ │ │ ├── util.py
│ │ │ ├── util.pyc
│ │ │ ├── util.pyo
│ │ │ ├── X509.py
│ │ │ ├── X509.pyc
│ │ │ └── X509.pyo
│ │ ├── M2Crypto-0.23.0-py2.7.egg-info
│ │ │ ├── dependency_links.txt
│ │ │ ├── PKG-INFO
│ │ │ ├── SOURCES.txt
│ │ │ └── top_level.txt
│ │ ├── miniupnpc-2.0-py2.7-linux-x86_64.egg
│ │ ├── netifaces-0.10.5-py2.7-linux-x86_64.egg
│ │ ├── opengraph-0.5-py2.7.egg
│ │ ├── protobuf-3.0.0b2-py2.7.egg
│ │ ├── psutil-1.2.1-py2.7-linux-x86_64.egg
│ │ ├── pycompat27.so
│ │ ├── repoze.lru-0.6-py2.7.egg
│ │ ├── requests-2.12.5-py2.7.egg
│ │ ├── Routes-2.4.1-py2.7.egg
│ │ ├── singledispatch-3.4.0.3-py2.7.egg
│ │ ├── six-1.10.0-py2.7.egg
│ │ ├── webencodings-0.5-py2.7.egg
│ │ ├── websocket_client-0.40.0-py2.7.egg
│ │ └── xmltodict-0.9.2-py2.7.egg
│ └── start-engine
├── app
│ └── tmp
│ ├── cache
│ ├── logs
│ │ └── source_node_8640.log
│ ├── metadata
│ ├── private
│ │ ├── 2019-09-22_1_private.acelive
│ │ ├── 2019-09-22_private.acelive
│ │ └── Testing_private.acelive
│ ├── public
│ │ ├── 2019-09-22_1.acelive
│ │ ├── 2019-09-22.acelive
│ │ ├── port_map.json
│ │ └── Testing.acelive
│ ├── run
│ └── state
├── config
│ └── config.json
└── src
├── cleanup.py
├── common.py
├── common.pyc
├── config.py
├── config.pyc
├── errors.py
├── errors.pyc
├── logger.py
├── logger.pyc
├── monitor_nodes.py
├── start_streamers.py
├── start_support_nodes.py
├── stop_nodes.py
├── update_metadata.py
├── utils.py
└── utils.pyc
[/details]

Did you carefully read wiki and “readme” at github - for what purpose you’re trying to specify “upload_to”, if you’re want to run source node only?

I think I read all and used find function, but I didn’t saw anything about upload-to so I thought that it has to be by default.

I removed it from config, but result is still the same.

Because I try to use m3u8 playlist I downgraded to 3.16 version because I found that in this forum that this is what I need to do.

I tried again and it didn’t work. Maybe my source is wrong? http://overtakefans.com/wp-content/themes/twentyseventeen/test_full/master.m3u8

root@xxx:~# python /opt/src/start_streamers.py
2019-09-22 20:09:45,354|MainThread|start|0 running instances, loaded 1 streams
2019-09-22 20:09:45,355|MainThread|start|start: engine=stable debug=1 name=2019-09-22_1 port=8640 cache=1073741824
2019-09-22 20:09:45,355|MainThread|start|create_transport_files: title=2019-09-22_1 url=http://overtakefans.com/wp-content/themes/twentyseventeen/test_full/master.m3u8 public=/opt/app/tmp/public/2019-09-22_1.acelive private=/opt/app/tmp/private/2019-09-22_1_private.acelive
base_url=http://overtakefans.com/wp-content/themes/twentyseventeen/test_full/master.m3u8 sid=0658d78054251512fd12debd562aa7ffc416aa8f:2019-09-22_1
created: hash=2fe1fe03e7af2b7b7291f3d16c9a4a7412d15cc9
2019-09-22 20:09:45,682|MainThread|start|create_transport_files: retval=0

Refer to https://developer.apple.com/documentation/http_live_streaming/example_playlists_for_http_live_streaming as proper HLS playlist example.
In your playlist URL start from “m3u8/main-feed/OTT…”, without “http://domain.com” part. You should check playlist playability in the VLC at least.

Thanks for your patients. The second attempt http://overtakefans.com/wp-content/themes/twentyseventeen/espn/master2.m3u8 I checked it in VLC it works fine, but still getting same message.

root@xxx:~# python /opt/src/start_streamers.py
2019-09-23 10:54:37,714|MainThread|start|0 running instances, loaded 1 streams
2019-09-23 10:54:37,714|MainThread|start|start: engine=stable debug=1 name=2019-09-22_1 port=8640 cache=1073741824
2019-09-23 10:54:37,715|MainThread|start|create_transport_files: title=2019-09-22_1 url=http://overtakefans.com/wp-content/themes/twentyseventeen/espn/master2.m3u8 public=/opt/app/tmp/public/2019-09-22_1.acelive private=/opt/app/tmp/private/2019-09-22_1_private.acelive
base_url=http://overtakefans.com/wp-content/themes/twentyseventeen/espn/master2.m3u8 sid=5c8b2cfc29ea76af5b95b10882407e77beb7f2be:2019-09-22_1
created: hash=e6ea3b3373fd8f24458f1321adb56c3006a8aaf4
2019-09-23 10:54:38,041|MainThread|start|create_transport_files: retval=0

Check engine log-files at “tmp/logs” for any error messages.

If I before start python /opt/src/start_streamers.py delete app folder I get

2019-09-23 10:54:37,714|MainThread|start|0 running instances, loaded 1 streams
2019-09-23 10:54:37,714|MainThread|start|start: engine=stable debug=1 name=2019-09-22_1 port=8640 cache=1073741824
2019-09-23 10:54:37,715|MainThread|start|create_transport_files: title=2019-09-22_1 url=http://overtakefans.com/wp-content/themes/twentyseventeen/espn/master2.m3u8 public=/opt/app/tmp/public/2019-09-22_1.acelive private=/opt/app/tmp/private/2019-09-22_1_private.acelive
base_url=http://overtakefans.com/wp-content/themes/twentyseventeen/espn/master2.m3u8 sid=5c8b2cfc29ea76af5b95b10882407e77beb7f2be:2019-09-22_1
created: hash=e6ea3b3373fd8f24458f1321adb56c3006a8aaf4
2019-09-23 10:54:38,041|MainThread|start|create_transport_files: retval=0

if I dont I get message like this.

root@xxx:/opt/src/config# python /opt/src/src/start_streamers.py
2019-09-21 12:35:35,259|MainThread|start|0 running instances, loaded 1 streams
2019-09-21 12:35:35,259|MainThread|start|start: engine=stable debug=1 name=Testing port=8640 cache=1073741824

Both times logs registered this

nohup: ignoring input
Cannot start private node without explicit 'upload to' nodes
nohup: ignoring input
Cannot start private node without explicit 'upload to' nodes

After I added ‘upload to’

logs register this message

nohup: ignoring input
2019-09-24 20:47:42,402|MainThread|acestream|use I array typecode
2019-09-24 20:47:42,402|MainThread|acestream|debug module: connecter
2019-09-24 20:47:42,403|MainThread|acestream|debug module: connecter_connection
2019-09-24 20:47:42,403|MainThread|acestream|debug module: download_live
2019-09-24 20:47:42,403|MainThread|acestream|debug module: single_download
2019-09-24 20:47:42,403|MainThread|acestream|debug module: downloader
2019-09-24 20:47:42,403|MainThread|acestream|debug module: encoder_connection
2019-09-24 20:47:42,403|MainThread|acestream|debug module: encoder
2019-09-24 20:47:42,403|MainThread|acestream|debug module: client_transporter
2019-09-24 20:47:42,410|MainThread|acestream|debug module: picker_client
2019-09-24 20:47:42,410|MainThread|acestream|debug module: storage
2019-09-24 20:47:42,411|MainThread|acestream|debug module: rerequester
2019-09-24 20:47:42,411|MainThread|acestream|debug module: multicast_pex
2019-09-24 20:47:42,411|MainThread|acestream|debug module: pieces
2019-09-24 20:47:42,411|MainThread|acestream|debug module: memory_usage
usage: acestreamengine [-h] --url URL [--stream-type STREAM_TYPE]
                       [--add-tracker ADD_TRACKER] [--bind BIND] [--port PORT]
                       [--state-dir STATE_DIR] [--cache-dir CACHE_DIR]
                       [--pid-file-dir PID_FILE_DIR]
                       [--hls-bad-manifest-max-errors HLS_BAD_MANIFEST_MAX_ERRORS]
                       [--hls-bad-manifest-retry-interval HLS_BAD_MANIFEST_RETRY_INTERVAL]
acestreamengine: error: unrecognized arguments: --public-transport-file /opt/app/tmp/public/2019-09-22_1.acelive --metadata-dir /opt/app/tmp/metadata --hls-broadcast-last-source-piece --hls-force-monotonic-sequence 1
2019-09-24 20:47:42,486|MainThread|acestream|node exited

by the way thanks for patience :-\

What version was used on latest attempts? You’ve wrote earlier

Because I try to use m3u8 playlist I downgraded to 3.16
- did you try with recent one? Do you have any other command-line options, except .conf file? On private node there no need to specify “public” dir.

I use 3.16

- did you try with recent one?
Yes I tryed with 3.149 and I get

root@hkl0:~# python /opt/src/start_streamers.py

2019-09-25 09:15:04,479|MainThread|start|0 running instances, loaded 1 streams
2019-09-25 09:15:04,480|MainThread|start|start: engine=stable debug=1 name=2019-09-22_1 port=8640 cache=1073741824
2019-09-25 09:15:04,480|MainThread|start|create_transport_files: title=2019-09-22_1 url=http://overtakefans.com/wp-content/themes/twentyseventeen/espn/master2.m3u8 public=/opt/app/tmp/public/2019-09-22_1.acelive private=/opt/app/tmp/private/2019-09-22_1_private.acelive
2019-09-25 09:15:05,063|MainThread|acestream|error during startup
Traceback (most recent call last):
  File "core.c", line 1791, in
  File "core.c", line 706, in
  File "core.c", line 23, in
ImportError: cannot import name pycompat
2019-09-25 09:15:05,108|MainThread|start|create_transport_files: retval=1
Do you have any other command-line options, except .conf file?
Please explane?
On private node there no need to specify "public" dir.
I want it to be pubic but for now without support node.

python scripts is intended to be used with latest engine version.

it’s a bug in the 3.1.49 version. Quick fix - copy files from attached archive to the /lib/acestreamengine dir of AceStream engine (overtakefan, in your case i already did this).

“private-node=1” is hardcoded in the “start_streamers.py” file, so you must edit it and change this value to 0.