Test Ace Stream software 3.0 for Ubuntu (En)

Ace Stream 3.0 for Ubuntu
Version Ace Stream 3.0.2 for Ubuntu has been released. The main innovation is support of a new protocol. A new version is available in repositories for Ubuntu 12.04, 13.10 and 14.04. Links to repositories and instructions how to install are described below.

Installing Ace Stream on Ubuntu from the repository

Step 1

Add link on appropriate repository into /etc/apt/sources.list.

Repository should be selected according to operating system.

Ubuntu 12.04:
deb http://repo.acestream.media/ubuntu/ precise main

Ubuntu 13.10:
deb http://repo.acestream.media/ubuntu/ saucy main

Ubuntu 14.04:
deb http://repo.acestream.media/ubuntu/ trusty main

Step 2

Installing public key. To do this you have to run the following command:

sudo wget -O - http://repo.acestream.media/keys/acestream.public.key | sudo apt-key add -

Step 3

Installing acestream-full package.

sudo apt-get update
sudo apt-get install acestream-full

The following packages are available in the repository for Ubuntu:

  • acestream-engine - engine
  • acestream-mozilla-plugin - plug-in for browsers
  • acestream-player - desktop player
  • acestream-player-data - set of common libraries for the player and plug-in
  • acestream-full - full package, including all of the above

Source codes of the player (Ace Player) are here: Bitbucket
P.S. We welcome all who wish not only to use the player, but also take an active part in its development and evolution.

We also remind you that all assemblies of the latest versions of engine 3.0 (without the player) are here: http://wiki.acestream.media/AceStream_3.0/en

Hey how comes timeshift is not working and live buffer is blank can i still use 2.1.6 player

Hi! In Linux Mint 17 I get these dependency errors. Is there a way to solve this?

[i]$ sudo apt-get install acestream-full
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
acestream-full : Depends: acestream-engine (>= 3.0.2-1precise1) but it is not going to be installed
Depends: acestream-player (>= 3.0.2-1precise1) but it is not going to be installed
Depends: acestream-mozilla-plugin (>= 3.0.2-1precise1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
[/i]

You may need to install python-apsw, for example for my Ubuntu 14.04:

$sudo apt-get install update
$sudo apt-get install python-apsw

Please make sure you enable necessary repos/sources in ‘Software & Update’->Downable from the internet, otherwise Ubuntu 14.04 may tell you no python-apsw package in your system…

Help me Please when I install AceStream on Linux ubuntu 14.10 KDE it writes this:

Построение дерева зависимостей
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
acestream-full : Зависит: acestream-player (>= 3.0.2-1trusty1) но он не будет установлен
Зависит: acestream-mozilla-plugin (>= 3.0.2-1trusty1) но он не будет установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

& don’t install Python-apsw ((( :frowning: :frowning: :frowning: :frowning: :frowning:
What can I do? :slight_smile: :slight_smile: :slight_smile: :slight_smile: :wink:

для чего это надо? Я всё равно никак не могу смотреть !!!

acestream seem to stop i run the stream from command line

2015-11-08 18:39:27,438|AceStreamCoreThread|acestream.BT.Encrypter.Connection|error in data_came_in()
Traceback (most recent call last):
File “core.c”, line 495, in
File “core.c”, line 422, in
File “core.c”, line 2384, in
File “core.c”, line 2663, in
File “ACEStream/Core/BitTornado/bencode.py”, line 96, in bdecode
ValueError: bad bencoded data
2015-11-08 18:39:27,439|AceStreamCoreThread|acestream.LM|_run: error
Traceback (most recent call last):
File “ACEStream/Core/APIImplementation/LaunchManyCore.py”, line 462, in _run
File “ACEStream/Core/BitTornado/ServerPortHandler.py”, line 283, in listen_forever
File “ACEStream/Core/BitTornado/RawServer.py”, line 279, in listen_forever
File “ACEStream/Core/BitTornado/SocketHandler.py”, line 695, in handle_events
File “core.c”, line 500, in
File “core.c”, line 495, in
File “core.c”, line 422, in
File “core.c”, line 2384, in
File “core.c”, line 2663, in
File “ACEStream/Core/BitTornado/bencode.py”, line 96, in bdecode
ValueError: bad bencoded data
2015-11-08 18:39:28,439|MainThread|acestream.streamer|signal_handler: got signal: signal=14
2015-11-08 18:39:28,440|MainThread|acestream.streamer|signal_handler: ignore signal 14
2015-11-08 18:39:28,440|MainThread|acestream.streamer|shutdown

it shut itself down 3.0.51 version

Has anyone been able to install AceStream to Ubuntu 16.04 LTS?

as i know not yet.

Не работает в Windows:

  • 46 версии FireFox - Требует цифр. подписания расширения, не загружается плеер
  • 38 ЕSR Firefox работает плагин, Требует цифр. подписания расширения

Please update on Ubuntu 16.04LTS :’(

64bits

1º Install libgnutls-deb0-28_3.3.15-5ubuntu2_amd64.deb from http://packages.ubuntu.com/wily/amd64/libgnutls-deb0-28/download

2ª Instalall acestream-player-compat_3.0.2-1.1_amd64.deb acestream-engine_3.0.3-0.2_amd64.deb acestream-player-data_3.0.2-1.1_amd64.deb acestream-player_3.0.2-1.1_amd64.deb from https://drive.google.com/folderview?id=0B7AdLMiZn4FzQ1hLZWxaQ19YY2c&usp=drive_web#list

32bits

1º install libgnutls-deb0-28_3.3.15-5ubuntu2_i386.deb from http://packages.ubuntu.com/wily/i386/libgnutls-deb0-28/download

2ºInstalar acestream-player-compat_3.0.2-1.1_i386.deb acestream-engine_3.0.3-0.2_i386.deb acestream-player-data_3.0.2-1.1_i386.deb acestream-player_3.0.2-1.1_i386.deb from https://drive.google.com/folderview?id=0B7AdLMiZn4FzQ1hLZWxaQ19YY2c&usp=drive_web#list